WordPress错误:无法启用插件,因为它引起了一个致命错误

在安装某些插件时,可能会遇到“无法启用插件,因为它引起了一个致命错误(fatal error)。Parse error: syntax error, unexpected $end in”的提示,出现这种情况的大多说原因都是因为插件代码中使用了<?php 的简写 <? 造成的。因为在 php5 版本中,一般都禁用了简写。问题知道了,解决的方法也就有了。

方法一:修改php.ini 配置

如果你有权限修改php.ini文件,打开这个文件,查找 short_open_tag ,将 short_open_tag = off 这个项目,修改设置为short_open_tag = on ,然后重启一下apache,即可解决。

WordPress错误:无法启用插件,因为它引起了一个致命错误

方法二:修改插件源代码

打开报错的那个插件的对应文件,也就是 Parse error: syntax error, unexpected $end in 后面出现路径的文件,然后搜索 <? 看看是不是有简写的 <? ,如果有,将它改为 <?php ,保存后一般即可启用这个插件了。

从中也给插件编写者一个提示:要尽量规范代码的编写,尽量不要使用 <? 简写。

原创文章,作者:Tony,如若转载,请注明出处:https://www.xxside.com/2182.html

发表评论

登录后才能评论